Ayuda Problema client - PlusEmu

  • 4 Respuestas
  • 395 Vistas

0 Usuarios y 1 Visitante están viendo este tema.

*

Desconectado KingAzzek

Problema client - PlusEmu
« en: Febrero 12, 2017, 06:30:15 pm »
Hola gente de la comunidad, les cuento... Estoy haciendo un hotel "habbe.es" y todo perfecto, hasta llegar al client. Tuve un problema antes que el que tengo ahora, el client cargaba hasta 76% y se reiniciaba, un ciclo sin fin.

Editando unas cuantas líneas del archivo client.php se solucionó ese problema. Pero ahora apareció otro que no tengo idea de como solucionarlo. El client carga perfectamente hasta 100%, luego aparece la vista principal del hotel una centesima de segundo, y se cae.

Espero que me puedan ayudar con este problema, ya configuré las swf correctamente, el client, todo. Dejaré algo que podría ser de utilidad más abajo para que vean si todo está correcto.

Client.php

Spoiler para Oculto:
<?php
/* ♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛\
   ░░░▒█ ▒█▀▀▀ ▀█▀ ▒█░▒█ ▒█▀▀▄ ▒█▀▀▀ ▒█▄░▒█     ▒█▀▀█ ▒█▀▄▀█ ▒█▀▀▀█
   ░▄░▒█ ▒█▀▀▀ ▒█░ ▒█▀▀█ ▒█░▒█ ▒█▀▀▀ ▒█▒█▒█ ▀▀▀ ▒█░░░ ▒█▒█▒█ ░▀▀▀▄▄
   ▒█▄▄█ ▒█▄▄▄ ▄█▄ ▒█░▒█ ▒█▄▄▀ ▒█▄▄▄ ▒█░░▀█     ▒█▄▄█ ▒█░░▒█ ▒█▄▄▄█
────────────────CMS de Uso Privado 2015  by Jeihden─────────────────────
\ ♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛♛*/
    ob_start();
    require_once 'global.php';
    $Functions->Logged("true");
   $myusername = $_SESSION['username'];
   $ticket = $Functions->GenerateTicket();
   $query = $db->query("UPDATE users SET  auth_ticket = '{$ticket}', ip_last = '" . USER_IP . "', last_used = '". time() ."' WHERE username = '" . $myusername . "'");
   $users = $db->query("SELECT rank FROM users WHERE username = '" . $myusername . "'");
   $user = $users->fetch_array();
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
        "No tienes permiso para ver enlaces. Registrarme ó Logearme">
<html xmlns="No tienes permiso para ver enlaces. Registrarme ó Logearme" xml:lang="en" lang="en" xmlns:og="No tienes permiso para ver enlaces. Registrarme ó Logearme" xmlns:fb="No tienes permiso para ver enlaces. Registrarme ó Logearme">
<?php global $db;$result = $db->query("SELECT * FROM cms_settings WHERE id = 1 LIMIT 1");if($result->num_rows > 0){while($data = $result->fetch_array()){ ?>
<title><?php echo $data['hotelname']; ?> ~ Cliente</title>
   <script type="text/javascript">
      var andSoItBegins = (new Date()).getTime();
      var ad_keywords = "";
      document.habboLoggedIn = true;
      var habboName = "<?php echo $_SESSION['username']; ?>";
      var habboReqPath = "No tienes permiso para ver enlaces. Registrarme ó Logearme";
      var habboStaticFilePath = "<?php echo CDN; ?>/web-gallery";
      var habboImagerUrl = "No tienes permiso para ver enlaces. Registrarme ó Logearme";
      var habboPartner = "";
      var habboDefaultClientPopupUrl = "No tienes permiso para ver enlaces. Registrarme ó Logearme";
      window.name = "habboMain";
      if (typeof HabboClient != "undefined") { HabboClient.windowName = "uberClientWnd"; }
   </script>
<link rel="shortcut icon" href="<?php echo CDN; ?>/web-gallery/v2/favicon.ico" type="image/vnd.microsoft.icon" />
<script src="<?php echo CDN; ?>/web-gallery/static/js/libs2.js" type="text/javascript"></script>
<script src="<?php echo CDN; ?>/web-gallery/static/js/visual.js" type="text/javascript"></script>
<script src="<?php echo CDN; ?>/web-gallery/static/js/libs.js" type="text/javascript"></script>
<script src="<?php echo CDN; ?>/web-gallery/static/js/common.js" type="text/javascript"></script>
<script src="<?php echo CDN; ?>/web-gallery/static/js/fullcontent.js" type="text/javascript"></script>
<link rel="stylesheet" href="<?php echo CDN; ?>/web-gallery/styles/style.css" type="text/css" />
<link rel="stylesheet" href="<?php echo CDN; ?>/web-gallery/styles/buttons.css" type="text/css" />
<link rel="stylesheet" href="<?php echo CDN; ?>/web-gallery/styles/boxes.css" type="text/css" />
<link rel="stylesheet" href="<?php echo CDN; ?>/web-gallery/styles/tooltips.css" type="text/css" />
<link rel="stylesheet" href="<?php echo CDN; ?>/web-gallery/styles/habboclient.css" type="text/css" />
<link rel="stylesheet" href="<?php echo CDN; ?>/web-gallery/styles/habboflashclient.css" type="text/css" />
<script src="<?php echo CDN; ?>/web-gallery/static/js/habboflashclient.js" type="text/javascript"></script>
<!DOCTYPE html>
<html lang="es_ES">
    <head>
        <meta charset="utf-8" />
        <meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no" />
        <meta name="description" content="Diversión sin limites" />
        <script type="text/javascript" src="<?php echo CDN; ?>/js/libs2.js"></script>
        <style type="text/css">
            * { margin: 0; padding: 0; }
            html, #flash-container { height: 100%; text-align: left; background-color: black; }
            #flash-container { position: absolute; overflow: hidden; left: 0; top: 0; right: 0; bottom: 0; }
        </style>
        <script type="text/javascript">
       var flashvars = {
                "client.allow.cross.domain": "1",
                "client.notify.cross.domain": "0",
                "connection.info.host": "habbe.es",
                "connection.info.port": "30000",
                "site.url": "habbe.es",
                "url.prefix": "No tienes permiso para ver enlaces. Registrarme ó Logearme",
                "client.reload.url": "No tienes permiso para ver enlaces. Registrarme ó Logearme",
                "client.fatal.error.url": "No tienes permiso para ver enlaces. Registrarme ó Logearme",
                "client.connection.failed.url": "No tienes permiso para ver enlaces. Registrarme ó Logearme",
                "external.variables.txt": "No tienes permiso para ver enlaces. Registrarme ó Logearme",
                "external.texts.txt": "No tienes permiso para ver enlaces. Registrarme ó Logearme",
                "productdata.load.url": "No tienes permiso para ver enlaces. Registrarme ó Logearme",
                "furnidata.load.url": "No tienes permiso para ver enlaces. Registrarme ó Logearme",
                "use.sso.ticket": "1",
                "sso.ticket": "<?php echo $ticket; ?>",
                "processlog.enabled": "1",
                "account_id" : "<?php echo $Functions->Get('id'); ?>",
                "client.starting" : "¡Por favor, espera <?php echo $Functions->Get('username'); ?>! <?php echo $data['hotelname']; ?> se está cargando",
                "flash.client.url": "No tienes permiso para ver enlaces. Registrarme ó Logearme",
                "user.hash" : "5690170255dbf26e0275377f436614c91d1a810d",
                "has.identity": "1",
                "flash.client.origin": "popup",
                "forward.type" : "2",
                "forward.id" : "0"
            };

         var params = {
            "base" : "<?php echo $data['flash_client_url']; ?>",
            "allowScriptAccess" : "always",
            "menu" : "true"
        };

      swfobject.embedSWF("<?php echo $data['habbo_swf']; ?>", "flash-container", "100%", "100%", "10.1.0", "No tienes permiso para ver enlaces. Registrarme ó Logearme", flashvars, params, null);
        </script>
    </head>
    <body>
        <div id="flash-container"></div>
    </body>
<?php } } else{ echo '<i>No se encuentra la tabla cms_settings</i>'; }?>
</html>
<?php ob_end_flush(); ?>

Este es el error del client, esto me sale.

Spoiler para Oculto:

Configurado el HK con las swf tal cual al client

Spoiler para Oculto:

*

Desconectado EasyMen

Re:Problema client - PlusEmu
« Respuesta #1 en: Febrero 12, 2017, 08:47:22 pm »
La configuración que has hecho en la HK no te va a servir de nada y te explico porque, quizá me equivoque. Pero me parece ver que el client.php lo has configurado a mano. En la CMS que estás usando la información se completa en una tabla llamada cms_settings, tú decidiste hacerlo desde el archivo directamente a mano (no está mal), pero hace que la tabla cms_settings no tenga ninguna función en cuestión de los directorios de las SWF y por ello hace que esa sección de la HK tampoco tenga función puesto que la información de esa sección lo que hace es actualizar la tabla mencionada antes.


Una vez dicho esto creo que el problema pueden ser alguno de estos:
- No has configurado bien alguno de los directorios.
- No has configurado bien los enlaces del external_variables
- En la carpeta extra de tu emulador no contienes el figuredata y el figuremap de tus SWF

*

Desconectado F3X

Re:Problema client - PlusEmu
« Respuesta #2 en: Febrero 13, 2017, 01:32:35 am »
¿Has conseguido solución?, puedo conectarme con TeamViewer, lo más probable es que el problema sean las SWFS.

*

Desconectado KingAzzek

Re:Problema client - PlusEmu
« Respuesta #3 en: Febrero 14, 2017, 04:06:59 am »
No tienes permiso para ver enlaces. Registrarme ó Logearme
¿Has conseguido solución?, puedo conectarme con TeamViewer, lo más probable es que el problema sean las SWFS.

0 Solución, podrías ayudarme... te mando mp

*

Desconectado AlgyGames

Re:Problema client - PlusEmu
« Respuesta #4 en: Febrero 14, 2017, 11:14:14 am »
No tienes permiso para ver enlaces. Registrarme ó Logearme
No tienes permiso para ver enlaces. Registrarme ó Logearme
¿Has conseguido solución?, puedo conectarme con TeamViewer, lo más probable es que el problema sean las SWFS.

0 Solución, podrías ayudarme... te mando mp

Hola!! Yo puedo ayudarte si quieres, saludos

 

Temas relacionados

  Asunto / Iniciado por Respuestas Último mensaje
7 Respuestas
1131 Vistas
Último mensaje Enero 17, 2017, 05:38:31 pm
por Blex
1 Respuestas
251 Vistas
Último mensaje Febrero 28, 2017, 11:04:31 pm
por Forbi
7 Respuestas
202 Vistas
Último mensaje Noviembre 04, 2017, 02:19:00 am
por Rapidinfo
1 Respuestas
172 Vistas
Último mensaje Febrero 01, 2018, 10:33:54 pm
por Userr
6 Respuestas
93 Vistas
Último mensaje Septiembre 21, 2018, 09:51:03 pm
por djdaniel91